AT&T St Louis outage

Incident Report for MOREnet Service

Resolved

Circuit have remained stable since restoration.
Posted Feb 19, 2026 - 21:54 CST

Monitoring

We are seeing the AT&T circuits restore. We have not received the reason for outage from AT&T yet but will follow up with them and continue to monitor for further issues.
Posted Feb 19, 2026 - 16:17 CST

Update

AT&T is reporting a major network issue in the St Louis area affecting service. AT&T technicians are troubleshooting to isolate the cause.
Posted Feb 19, 2026 - 15:44 CST

Investigating

At about 1:30 MOREnet members with a connection thru ATT&T out of St Louis have lost internet connection. MOREnet engineers have engaged AT&T technicians. We will update as information becomes available
Posted Feb 19, 2026 - 13:50 CST
This incident affected: MOREnet Network (MOREnet Internet, MOREnet Aggregation, Carrier Network).