Internet Disruptions

Incident Report for MOREnet Service

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 21:54 CST

Update

The main issue has been localized to a particular vendor. We are continuing to investigate any outliers, and engage the vendor to find the root cause of the 10am disruption. The noon time disruption was in relation to a high volume attack that has been identified and mitigated. We are currently monitoring that incident in case additional action is needed.
Posted Feb 19, 2026 - 15:44 CST

Investigating

Members have reported a couple 10 minutes outages around 10:10am and noon today. We are currently investigating what may have caused the disruption in service.
Posted Feb 19, 2026 - 13:39 CST
This incident affected: MOREnet Network (MOREnet Internet, Internet2 Network, MOREnet Backbone, MOREnet Aggregation, MOREnet Fiber, Carrier Network).