A network fault with a local provider in Branson, MO caused service disruption. Stability returned before Lumen intervention. Lumen NOC is seeking more details from the provider about the outage. A final notification will be provided once we have more information.
MOREnet NOC
Posted Oct 28, 2025 - 10:55 CDT
Investigating
We are currently investigating a possible cut on Lumen backhaul. Affected sites are:
Aurora Branch Barry-Lawrence Regional Library Eagle Rock Branch Barry-Lawrence Regional Library Main Branch - Stone County Library Christian County Library District - Ozark Branch St. Clair County Library Shell Knob 78 Blue Eye R-V Sheldon R-VIII Northeast Vernon County R-I (High School) Thomasville Library - Oregon County Library District Blue Eye Branch - Stone County Library Mt Vernon Branch Barry-Lawrence Regional Library Lakeland R-III
Posted Oct 28, 2025 - 10:00 CDT
This incident affected: MOREnet Network (MOREnet Aggregation).