Lumen crews isolated a broken fiber in a buried handhole. The fiber was repaired, thus restoring impacted services to a stable state. Validations were performed confirming all associated alarms are clear and services have returned to a stable state.
MOREnet NOC
Posted May 08, 2026 - 14:02 CDT
Update
Lumen has engaged their own teams as well as the local exchange carrier to help locate the damage.
Posted May 07, 2026 - 15:53 CDT
Identified
Lumen has confirmed a transport line down in their network. The Lumen Optical team has been engaged to dispatch and locate damage. Updates will follow.
MOREnet NOC
Posted May 07, 2026 - 15:47 CDT
Update
We are continuing to investigate this issue.
Posted May 07, 2026 - 14:39 CDT
Investigating
MOREnet engineers are investigating a possible fiber cut affecting some Lumen aggregation. Updates will follow.
Affected sites: Leesville R-IX Mirabile C-1 Appleton City R-II Kingsville R-I Hudson R-IX Odessa Branch - Trails Regional Library Hardin-Central C-2 (High School) Oak Hill R-I Calhoun R-VIII
MOREnet NOC
Posted May 07, 2026 - 14:21 CDT
This incident affected: MOREnet Network (MOREnet Backbone, MOREnet Aggregation).