Brightspeed & Lumen fiber hit near Belle, MO

Incident Report for MOREnet Service

Resolved

This incident has been resolved.

Root Cause: A fiber cut in Belle, MO, impacted client services.
Fix Action: The fiber was spliced, thus restoring client services to a stable condition.

MOREnet NOC
Posted Nov 20, 2025 - 08:38 CST

Identified

Brightspeed and Lumen NOC's are standing by for confirmation that excavation is underway.

MOREnet NOC
Posted Nov 19, 2025 - 20:21 CST

Update

A secondary LEC fiber Repair Team is en route to the fault site with a two-hour ETA. The next update will be issued upon their arrival.

MOREnet NOC
Posted Nov 19, 2025 - 17:06 CST

Update

A 24-strand cut fiber was identified due third-party construction activity in the Belle, MO vicinity. Splicing crews are on their way.

MOREnet NOC
Posted Nov 19, 2025 - 14:29 CST

Investigating

Fiber has been hit. Both vendors have been engaged for dispatch. Affected sites are:

Maries County Library Belle - Heartland Regional Library System
Maries Co. R-II
Maries Co. R-II - Middle School

Updates will follow.

MOREnet NOC
Posted Nov 19, 2025 - 13:09 CST
This incident affected: MOREnet Network (MOREnet Aggregation).