Aggregation Fiber Cut

Incident Report for MOREnet Service

Resolved

This incident has been resolved.
Posted Jun 10, 2026 - 07:39 CDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 10, 2026 - 06:43 CDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 10, 2026 - 06:41 CDT

Update

Circuits are back up. Turns out it was a problem in the cross connect within the carrier hotel in KC.
Posted Jun 10, 2026 - 05:06 CDT

Identified

technicians have been dispatched to the site to begin repairs. No ETR given.
Posted Jun 10, 2026 - 00:24 CDT

Update

We are continuing to investigate this issue.
Posted Jun 09, 2026 - 21:53 CDT

Investigating

MOREnet engineers are investigating a possible fiber cut affecting our BlueBird aggregation. Updates will follow.

Affected sites:
A T Still University of Health Sciences
Cainsville R-I
Cameron R-I
Concordia Branch - Trails Regional Library
Concordia High School - Concordia R-II
Corder Branch - Trails Regional Library
Drexel Branch - Cass County Library
Drexel R-IV
East Buchanan Co. C-I
East Lynne 40
Garden City Branch - Cass County Library
Grundy R-V
Hamilton R-II
Holden R-III
Leeton R-X
Linn Co. R-I
Malta Bend R-V
Meadville R-IV
Mercer County Library
Nodaway-Holt R-VII High School
North Central Missouri College
North Harrison Co. R-III
North Mercer Co. R-III
Northeast Nodaway R-V
Northwest Elementary - Pettis Co. R-V
Pattonsburg R-II
Polo R-VII
Princeton R-V
Ridgeway R-V
South Nodaway Co. R-IV
Sullivan County Library
Sullivan County Memorial Hospital
Sweet Springs R-VII
Wellington-Napoleon R-IX
West Nodaway Co. R-I

MOREnet NOC
Posted Jun 09, 2026 - 20:50 CDT
This incident affected: MOREnet Network (MOREnet Internet, MOREnet Aggregation).