Fiber Cut St Louis area

Incident Report for MOREnet Service

Resolved

This incident has been resolved.
Posted Aug 28, 2025 - 09:25 CDT

Update

We thank you for your continued patience on this over 24 hr outage. Crews are currently splicing fiber. No ETR
Posted Aug 27, 2025 - 15:02 CDT

Update

Our most recent update is the carrier is pulling in new fiber now. Once complete they can begin splicing.
Posted Aug 27, 2025 - 09:44 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 26, 2025 - 21:22 CDT

Update

Telco technicians continue to investigate location of damaged fiber.
Posted Aug 26, 2025 - 19:54 CDT

Investigating

At about 2:30pm MOREnet network experienced an outage in the St Louis area. We have contacted the telco who suspects fiber cut and enroute to diagnose.
Posted Aug 26, 2025 - 15:37 CDT
This incident affected: MOREnet Network (MOREnet Backbone, MOREnet Aggregation, MOREnet Fiber).