Lumen Outage - KC

Incident Report for MOREnet Service

Resolved

This incident has been resolved.
Posted Jun 11, 2026 - 16:53 CDT

Update

We are continuing to monitor for any further issues.
Posted Jun 11, 2026 - 13:36 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 11, 2026 - 13:04 CDT

Update

resolution appears not to be stable. As such, I have down graded status until service is stablized.
Posted Jun 11, 2026 - 11:31 CDT

Update

Issue is still being worked on aas equipment is being systematically rebooted.
Posted Jun 11, 2026 - 11:04 CDT

Identified

The vendor identified equipment impacted by a recent power failure. After restoring power, the equipment failed to initialize successfully, and a continued power issue is suspected. Troubleshooting efforts are ongoing.
Posted Jun 11, 2026 - 10:29 CDT

Investigating

Sites:
Appleton City R-II
Belleview R-III
Blue Eye Branch - Stone County Library
Calhoun R-VIII
Centerville Branch (Main) - Reynolds County Library
Centerville R-I
Chilhowee R-IV
Craig R-III
Hardin-Central C-2 (High School)
Hudson R-IX
Hurley R-I
Kingsville R-I
Lakeland R-III
Manes R-V
Mirabile C-1
Oak Hill R-I
Odessa Branch, Trails Regional
Osage Co. R-I
Pleasant Hill Branch - Cass County Library
Shawnee R-III
Sheldon R-VIII
Shell Knob 78
Thomasville Library - Oregon County Library District

Description:
Sites all down about 30 minutes ago, Lumen outage under investigation
Posted Jun 11, 2026 - 08:24 CDT
This incident affected: MOREnet Network (MOREnet Internet, Carrier Network).