Services have been migrated to an alternate path with Lumen thus restoring services. We are monitoring the status until an all clear is given.
Posted Feb 07, 2026 - 15:56 CST
Update
Repair efforts continue.
Posted Feb 07, 2026 - 14:18 CST
Update
traffic control is now fully in place, allowing the splicing team to access the splice enclosure safely. The splicer has opened the enclosure and is currently conducting a visual inspection of the equipment. Troubleshooting and splicing preparations are expected to begin shortly.
Posted Feb 07, 2026 - 12:05 CST
Update
traffic control and a splice crew are enroute to the site estimated to arrive within the next 15 minutes
Posted Feb 07, 2026 - 11:49 CST
Update
Listing of sites impacted by the Lumen outage: Aurora Branch Barry-Lawrence Regional Library Blue Eye R-V Blue Eye Branch - Stone County Library Christian County Library District - Ozark Branch Dadeville R-II Eagle Rock Branch Barry-Lawrence Regional Library Hurley R-I Lakeland R-III Main Branch - Stone County Library Manes R-V Mt Vernon Branch Barry-Lawrence Regional Library Northeast Vernon County R-I (High School) Sheldon R-VIII Shell Knob 78 St. Clair County Library Thomasville Library - Oregon County Library District Willow Springs Public Library
Posted Feb 07, 2026 - 09:03 CST
Update
MODOT has put a safety hold on further repair attempts until noon today.
Posted Feb 07, 2026 - 08:08 CST
Update
Due to unforeseen circumstances splicers are actively engaged in another fiber event and will likely be forced into a safety break due to the time working. Crews will be re-engaged in the morning on February 07, 2026. The next update will be provided once crews are enroute or as new information becomes available
Posted Feb 06, 2026 - 22:39 CST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 06, 2026 - 19:24 CST
Update
Field Operations is on site, and initial fiber readings indicate the fault is approximately 3 miles from the testing point.
Posted Feb 06, 2026 - 18:31 CST
Update
technicians have been dispatched to locate and repair damaged fiber. no ETR given.
Posted Feb 06, 2026 - 16:45 CST
Update
Lumen discovered a service impact in Gray Summit, MO. Your customer trouble ticket has been related to a network event; The Lumen Network Operations Center (NOC) is investigating to determine the cause. Please be advised that live updates for this event will be relayed at a minimum of hourly unless otherwise stated or as relevant details evolve.
Posted Feb 06, 2026 - 15:44 CST
Investigating
17 sites offline in KC Area due to a Lumen fault. Under investigation, no ETR currently as it has just been reported.
Posted Feb 06, 2026 - 15:27 CST
This incident affected: MOREnet Network (MOREnet Internet, Carrier Network).