Charter has implemented a fix. We will continue monitoring over the next several hours to ensure stability during peak hours for the affected sites.
MOREnet NOC
Posted Nov 04, 2025 - 08:42 CST
Update
As bandwidth increased this morning, we observed packet loss accumulating again. All data has been relayed to Charter’s NOC, and they are actively working toward a resolution. The issue has been escalated further for higher-level review. Thank you for your patience as we await Charter’s updates.
MOREnet NOC
Posted Nov 03, 2025 - 10:36 CST
Update
Packet loss has shown improvement. We’re continuing to work with Charter’s Carrier team to further clean up the issue and monitor results. This process will continue over the next few days as we verify stability. Additional updates will be provided as we progress.
MOREnet NOC
Posted Nov 01, 2025 - 11:34 CDT
Identified
Charter is still working on tracking down the cause and implementing a fix. This has been escalated higher.
MOREnet NOC
Posted Oct 31, 2025 - 08:49 CDT
Update
The incident has been escalated to Tier 2 Carrier with Charter. Performance has improved slightly, but we are still seeing significant loss. Updates will follow.
MOREnet NOC
Posted Oct 30, 2025 - 16:07 CDT
Update
Charter has escalated this to their carrier group. Updates will follow.
MOREnet NOC
Posted Oct 30, 2025 - 11:37 CDT
Investigating
Spectrum is having a major disruption in their network causing packet loss and drops. We are working with them now to determine the cause and apply a fix.
Fredericktown Branch - Ozark Regional Library Kirkwood Public Library Pleasant Hill R-III Valley Park Community Library Kearney R-I Richmond Heights Memorial Library Southern Boone County Public Library - Daniel Boone Regional Library Bourbon Branch - Crawford County Library District Warren County R-III Wright City R-II
Updates will follow.
MOREnet NOC
Posted Oct 30, 2025 - 09:02 CDT
This incident affected: MOREnet Network (MOREnet Aggregation).