Wright City Area Otage
Incident Report for MOREnet Service
Update
We are continuing to investigate this issue.
Posted Oct 12, 2024 - 06:53 CDT
Update
no update at this time
Posted Oct 11, 2024 - 19:30 CDT
Investigating
outage due to network fauult, ETR given 11pm.
Posted Oct 11, 2024 - 17:54 CDT
This incident affects: MOREnet Network (Carrier Network).