K-Power Net Fiber Cut

Incident Report for MOREnet Service

Resolved

Services restored at approximately 3:30AM after damaged fibers were repaired.
Posted Nov 08, 2025 - 07:09 CST

Update

Splicers are continuing to work to repair two damaged cables near Kansas city. No ETR at this time.
Posted Nov 07, 2025 - 20:29 CST

Update

Fiber damage was located and repair crews are onsite. Restoration efforts have begun but no ETR at this time.
Posted Nov 07, 2025 - 16:18 CST

Identified

K-Power Net has identified a suspected fiber cut in the Kansas City area causing an outage the below MOREnet circuits. Field technicians are still isolating and troubleshooting.

El Dorado Springs R-II
Butler R-V
Davis R-XII
Midway R-I
Cedar County Library El Dorado Branch
Posted Nov 07, 2025 - 13:29 CST
This incident affected: MOREnet Network (Carrier Network).