Lumen Fiber Down

Incident Report for MOREnet Service

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 12:32 CST

Update

The splice team is working on the final three splices for the 96-count cable. Additional splicers are en route to assist with restoration on the 288-count cable.

MOREnet NOC
Posted Nov 19, 2025 - 10:07 CST

Update

Additional testing indicates the light signal is traveling 23.7 miles along the fiber path. The Outside Plant Engineer (OSPE) is reviewing test results and comparing them with network records to determine the location of the fault.

MOREnet NOC
Posted Nov 19, 2025 - 10:07 CST

Identified

The Lumen NOC has confirmed that a planned maintenance scheduled to be completed by 12:00 GMT on November 19, 2025 has exceeded the defined window. Splicing was completed; however, some services remain impacted. Field Operations has been engaged to test the affected fiber span in an effort to isolate the reason for the continued impact, and is onsite setting up test equipment. Splicers are onsite, and will remain on standby in the event that additional splicing is required.
Posted Nov 19, 2025 - 08:44 CST

Investigating

Lumen performed scheduled fiber maintenance at midnight, and it appears an issue was introduced during that work. We have engaged Lumen’s NOC and are awaiting updates.


Chilhowee R-IV
Craig R-III
Pleasant Hill Branch - Cass County Library
Shawnee R-III

Updates will follow.

MOREnet NOC
Posted Nov 19, 2025 - 08:41 CST
This incident affected: MOREnet Network (MOREnet Aggregation).