Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 15, 2025 - 00:01 CDT
Scheduled
Sites: Appleton City R-II Boonslick Regional Lib - Cole Camp Br Calhoun R-VIII Cass County Lib - Pleasant Hill Br Chilhowee R-IV Cole Camp R-I Craig R-III Green Ridge R-VIII Hardin Central C-2 High School Hudson R-IX Kingsville R-I Leesville R-IX Montrose R-XIV Oak Hill R-I Oakgrove R-VI Shawnee R-III Smithton R-VI Trails Regional Lib - Odessa Br
Outage: up to 6 hours
Description: Lumen's 3rd party provider will be performing maintenance during this window. The nature of this work is to replace a section of fiber cable to proactively avoid unplanned outages due to the Wisconsin Department of Transportation's (WisDOT) road move project. An additional night, 5/16/25, may be needed to complete work. Expects outages throughout the maintenance period.
Posted May 07, 2025 - 08:51 CDT
This scheduled maintenance affected: MOREnet Network (Carrier Network).