Fiber cut in Cuba, MO.

Incident Report for MOREnet Service

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 10:16 CST

Update

Vendor Fiber Crews are currently on site accessing the damage due to vandalism. Current plan is to splice in new fiber. No ETR at this time.
Posted Feb 25, 2026 - 09:41 CST

Investigating

We are currently investigating this issue.
Posted Feb 25, 2026 - 03:49 CST
This incident affected: MOREnet Network (MOREnet Backbone, MOREnet Fiber).