Root Cause: A fiber issue within a partner provider's network in Jefferson City, MO impacted client services. Fix Action: The partner provider cleaned and reterminated their fiber optic connections, thus restoring services to a stable state
Posted Jul 02, 2026 - 11:37 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 02, 2026 - 10:33 CDT
Investigating
Sites: Appleton City Public Library Green Ridge R-VIII Henry Co. R-I Hudson R-IX Lenora Blackmore Branch - Henry County Library Montrose R-XIV Main Branch Harrisonville - Cass County Library Oak Hill R-1 Strasburg C-3 as well as sites in Jefferson City, MO
Description: Link flapping (i.e. intermittent outages) in the last hour. Vendor ticket has been reopened and they are working on the issue. Will update as info is provided.
Posted Jul 02, 2026 - 09:25 CDT
This incident affected: MOREnet Network (MOREnet Internet, Carrier Network).