Fiber cut in Rolla

Incident Report for MOREnet Service

Update

Vendor has completed some spices and expects to be hands off at 10am CST.
Posted Nov 18, 2025 - 09:26 CST

Update

Splice crews are on site continuing to splice. Current etr is noon.
Posted Nov 18, 2025 - 07:32 CST

Update

Damage has been located and vendor will start repairs as soon as splice crews are on site. No etr has been given by fiber provider.
Posted Nov 17, 2025 - 23:08 CST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 17, 2025 - 23:08 CST

Update

Damage has been located and vendor will start repairs as soon as splice crews are on site. No etr has been given by fiber provider.
Posted Nov 17, 2025 - 18:04 CST

Investigating

We are investigating the issue.
Posted Nov 17, 2025 - 18:04 CST
This incident affects: MOREnet Network (MOREnet Fiber).