MOREnet fiber cut between Cuba and Washington, MO.

Incident Report for MOREnet Service

Resolved

This incident has been resolved.
Posted Apr 22, 2026 - 18:24 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 22, 2026 - 12:21 CDT

Investigating

We are currently investigating this issue.
Posted Apr 22, 2026 - 10:14 CDT
This incident affected: MOREnet Network (MOREnet Backbone, MOREnet Fiber).