Underlying carrier maintenance in Osceola area

Incident Report for MOREnet Service

Monitoring

Service has been restored. We will continue to monitor for the duration of the scheduled maintenance window.
Posted Jun 04, 2026 - 01:00 CDT

Identified

Underlying carrier is performing fiber maintenance in the Osceola area. Traffic is rerouting around the work.
Posted Jun 04, 2026 - 00:25 CDT
This incident affects: MOREnet Network (MOREnet Backbone, MOREnet Fiber).