Fiber Cut

Incident Report for MOREnet Service

Resolved

Lumen higher level transport team has replaced the suspected faulty card and that has corrected the issue. Connection has been stable.

MOREnet NOC
Posted Jul 18, 2025 - 08:02 CDT

Update

The replacement card ETA is 1am CDT. Upon arrival, field will work with Lumen Transport NOC to replace.

MOREnet NOC
Posted Jul 17, 2025 - 22:45 CDT

Update

The Lumen transport NOC has ordered a replacement card and is awaiting the part, no ETA.

Updates to follow.

MOREnet NOC
Posted Jul 17, 2025 - 19:59 CDT

Update

Services have been restored. We are actively engaged with Lumen to identify the root cause and prevent any further disruptions. They have reported equipment failures as a contributing factor. We are escalating the issue with their NOC and will provide updates as they become available.

MOREnet NOC
Posted Jul 17, 2025 - 14:48 CDT

Identified

Lumen has identified a cut on their fiber. Efforts are being made to determine where the damage is occurring. Affected sites are as follows:

Washington County Library
Maries County Library Belle - Heartland Regional Library System
Bunker Branch - Reynolds County Library
Lesterville Branch - Reynolds County Library
Bunker R-III
Recklein Memorial Branch - Crawford County Library District
Wright City Branch - Scenic Regional Library
Centerville Branch (Main) - Reynolds County Library
Centerville R-I
Belleview R-III
South Iron Co. R-I (High School)
Lesterville R-IV
Laddonia Branch - Mexico-Audrain County Library

Updates will follow.

MOREnet NOC
Posted Jul 17, 2025 - 14:30 CDT
This incident affected: MOREnet Network (MOREnet Aggregation).