Lumen Outage

Incident Report for MOREnet Service

Resolved

A 10G backbone fiber link in Lumen's network bounced briefly causing the outage. Lumen technicians are trying to identify the cause of the bounce but all services have restored.
Posted Sep 04, 2025 - 15:10 CDT

Investigating

Lumen is experiencing a networking outage affecting the below circuits. Lumen technicians are currently troubleshooting to identify the cause.

Circuits:

Manes R-V
Dadeville R-II
Hurley R-I
Willow Springs Public Library
Posted Sep 04, 2025 - 14:05 CDT
This incident affected: MOREnet Network (Carrier Network).