Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 17, 2025 - 00:01 CDT
Scheduled
SIte: A T Still University of Health Sciences Albany Carnegie Public Library Atterbury Memorial Library - Little Dixie Regional Library Bluebird NOC 24/7 Trouble Line: (877) 766-2662 Cainsville R-I Canton R-V Cass County Library - Drexel Cass County Library - Garden City Concordia High School - Concordia R-II Drexel R-IV East Buchanan Co. C-I East Lynne 40 Franklin Co. R-II Gallatin R-V Gasconade Co. R-II Grundy County-Jewett Norris Library Grundy R-V Hamilton R-II Harrisburg R-VIII Holden R-III Johnson Co. R-VII La Plata R-II (High School) Lafayette Co. C-I High School Lathrop R-II Leeton R-X Linn Co. R-I Lone Jack C-6 Main Library - Daviess County Library Malta Bend R-V Meadville R-IV Mercer County Library Mexico-Audrain County Library - Farber Mound City Public Library Nodaway-Holt R-VII High School North Central Missouri College North Harrison Co. R-III North Mercer Co. R-III Northeast Nodaway R-V Northwest Elementary - Pettis Co. R-V Northwest Missouri State University Paris R-II Pattonsburg R-II Polo R-VII Princeton R-V Ridgeway R-V Robertson Memorial Library Scenic Regional Library - New Haven South Callaway Co. R-II South Nodaway Co. R-IV Sullivan County Library Sullivan County Memorial Hospital Sweet Springs R-VII Trails Regional Library- Concordia Trails Regional Library- Corder Trails Regional Library-Holden Wellington-Napoleon R-IX Wentzville R-IV West Nodaway Co. R-I Winfield R-IV Elementary School
Outage: n/a
Description: Equipment reconfiguration and maintenance will be done during this time frame. No downtime is expected do to failover. A backup night of 7/18/25 may be needed to complete work.
Posted Jul 15, 2025 - 13:23 CDT
This scheduled maintenance affected: MOREnet Network (MOREnet Internet, Carrier Network).