AT&T has completed splicing and are hands off. Circuits have remained stable since restoring around 12:20AM.
Posted Apr 01, 2026 - 07:56 CDT
Monitoring
Circuits restored at approximately 12:20AM. We have not received the hands off notification from AT&T at this time. We will continue to monitor.
Posted Apr 01, 2026 - 01:43 CDT
Update
Splicing efforts are continuing. AT&T has provided an ETR of 9:40AM April 1st.
Posted Mar 31, 2026 - 21:31 CDT
Update
Splicing efforts continue. Per AT&T - a 144 count fiber is ribbon but is gel filled and then a 216 count fiber is singles gel filled so this will slow down progress a bit. Still no ETR.
Posted Mar 31, 2026 - 19:32 CDT
Update
Fiber repair work continues. AT&T has not provided an ETR yet.
Posted Mar 31, 2026 - 16:51 CDT
Update
Damaged cable has been located and contractors are enroute with ETA of 1-hour.
Posted Mar 31, 2026 - 14:04 CDT
Identified
AT&T field and central office technicians have identified a fiber cut with approximately 178' of damaged fiber. Technicians are still assessing the complete damage. No ETR at this time.
Posted Mar 31, 2026 - 10:52 CDT
Update
AT&T has confirmed a major network failure in the St Louis area. They are continuing to isolate the cause. This outage affects the circuits listed below:
Affton 101 AT Still University St Louis Boncl R-X Camden Co Library Osage Beach Branch Fulton 58 Gideon 37 Hancock Place Hannibal 60 Hannibal LaGrange College John Burroughs School Leopold R-III MACC Hannibal Campus MACC Mexico Campus Maplewood Public Library Mexico-Audrain Co Library Mexico Branch Mississippi Co Library Mitchell Memorial Library Mississippi Co Library Main Branch New Madrid Rhodes Memorial Library Poplar Bluff Public Library Southeast Mo State University Kennett Campus Union R-XI Webster Groves Public Library Zalma R-V
Posted Mar 31, 2026 - 10:16 CDT
Investigating
We are currentling investigating a large AT&T outage affecting circuits terminating in our St Louis hub. We have engaged AT&T for additional troubleshooting.
Posted Mar 31, 2026 - 09:50 CDT
This incident affected: MOREnet Network (Carrier Network).