St Louis Area outage

Incident Report for MOREnet Service

Resolved

This incident has been resolved.
Posted Jun 16, 2026 - 11:22 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 14, 2026 - 16:13 CDT

Identified

The issue has been identified with the last mile provider. But no ETR at this time
Posted Jun 14, 2026 - 06:57 CDT

Investigating

Vendor contacted about outage in St Louis area. They are currently investigating.
Posted Jun 14, 2026 - 02:50 CDT
This incident affected: MOREnet Network (MOREnet Internet, MOREnet Backbone, MOREnet Fiber).