Drop in Internet connectivity at 2:50PM 4/16/2026

Incident Report for MOREnet Service

Resolved

Routing appears stable. MOREnet will continue to monitor for further instability.
Posted Apr 17, 2026 - 14:45 CDT

Monitoring

An upstream internet vendor's router crashed in Kansas City, which forced a reboot of the affected system. All services are restored, but the internet provider is working with the equipment vendor to determine the cause of the crash. MOREnet will continue to monitor the situation.
Posted Apr 17, 2026 - 11:31 CDT

Investigating

There was a drop in connectivity through a MOREnet vendor resulting in a disruption in traffic of about 3 minutes. We are investigating the reason for this incident.
Posted Apr 16, 2026 - 15:31 CDT
This incident affected: MOREnet Network (MOREnet Internet, Internet2 Network).