MOREnet fiber issue in St Louis, MO

Incident Report for MOREnet Service

Resolved

This incident has been resolved.
Posted Mar 26, 2026 - 21:16 CDT

Investigating

We are currently investigating this issue.
Posted Mar 26, 2026 - 15:46 CDT