Lumen Outage 9/11/25

Incident Report for MOREnet Service

Resolved

splicing completed, all clear.
Posted Sep 11, 2025 - 21:46 CDT

Update

Crews reports the first side has been spliced and the construction crews are prepping the second side. Sites have recovered but the work is not completed. No ETTR is available for hands off.
Posted Sep 11, 2025 - 20:33 CDT

Identified

as of 5:48pm local carrier identified damaged fiber. work is being done to escavate and repair. no ETR given.
Posted Sep 11, 2025 - 20:06 CDT

Update

no updates given after multiple escalations
Posted Sep 11, 2025 - 16:23 CDT

Update

escalated again requesting updates
Posted Sep 11, 2025 - 15:17 CDT

Update

ticket escalated, update requested
Posted Sep 11, 2025 - 13:59 CDT

Update

issue has been transferred to a local carrier who is working on isolating the issue. No ETR given.
Posted Sep 11, 2025 - 12:15 CDT

Update

We are continuing to investigate this issue.
Posted Sep 11, 2025 - 10:33 CDT

Update

We are continuing to investigate this issue.
Posted Sep 11, 2025 - 10:15 CDT

Investigating

Sits:

Lakeland SD
St ClairCouty Library

Lumen outage noted with ticket created with vendor . No ETR as of now while investigation begins.
Posted Sep 11, 2025 - 10:11 CDT
This incident affected: MOREnet Network (MOREnet Internet, Carrier Network).