MOREnet fiber outage

Incident Report for MOREnet Service

Resolved

This incident has been resolved.
Posted Jul 08, 2026 - 14:01 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 06, 2026 - 13:17 CDT

Investigating

Due to a fiber issue and power outage, customers on our SEMO necklace in the Springfield area experienced a brief outage. We appreciate your patience.
Posted Jul 06, 2026 - 09:44 CDT
This incident affected: MOREnet Network (MOREnet Internet, MOREnet Fiber).