BrightSpeed Outage 1/18/26

Incident Report for MOREnet Service

Resolved

Issue has been resolved, all clear from vendor
Posted Jan 19, 2026 - 07:22 CST

Update

all clear not received as of yet, but systems are operable.
Posted Jan 18, 2026 - 11:25 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 18, 2026 - 11:24 CST

Investigating

Sites:
NE Vernon Co SD

Description:
Fiber fault, known condition: Brightspeed Ticket #: CS13811778, MORENET - 507390367, currently being worked. They are in the isolation phase of the work. The cell towers are also down so updates are not forth coming until significant repair work has been done.
Posted Jan 18, 2026 - 08:28 CST
This incident affected: MOREnet Network (MOREnet Internet, Carrier Network).