Aggregation Fiber Cut

Incident Report for MOREnet Service

Resolved

This incident has been resolved.
Posted Jun 11, 2026 - 07:35 CDT

Identified

Vendor has found a switch that died. They are working on replacing it.
Posted Jun 10, 2026 - 10:37 CDT

Investigating

MOREnet engineers are investigating a down link to our Lumen connection. Updates will follow.

Affected sites:
Appleton City R-II
Aurora Branch Barry-Lawrence Regional Library
Belleview R-III
Blue Eye R-V
Bronaugh R-VII
Calhoun R-3
Cass Co, Pleasant Hill Br
Centerville Branch - Reynolds County Library
Centerville R1
Chilhowee R-IV
Craig R-III
Crane R-III
Hardin-Central
Hudson R-IX
Hurley R-I
Kingsville R-I
Lakeland R-III
Leesville R-IX
Main Branch - Stone County Library
Manes R-V
Mirabile C1
Oak Hill R-I
Odessa Branch, Trails Regional Library
Osage Co R-I
Shawnee R-III
Sheldon R-VIII
Shell Knob
St Clair Co Lib
Stone Co Lib Blue
Thomasville-Oregon Lib

MOREnet NOC
Posted Jun 10, 2026 - 09:00 CDT
This incident affected: MOREnet Network (MOREnet Aggregation).