Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 15, 2025 - 00:02 CDT
Scheduled
Sites; Barry-Lawrence Memorial Lib - Aurora Br Barry-Lawrence Memorial Lib - Eagle Rock Br Barry-Lawrence Memorial Lib - Mt Vernon Br Barry-Lawrence Memorial Lib - Shell Know Br Blue Eye R-V Bronaugh R-VII Carter Co Library Christian Co Lib - Ozark Br Dadeville R-II Hurley R-I Lakeland R-III Manes R-V Northeast Vernon Co R-1, High School Oregon Co Library - Thomasville Br Osage Co R-I St Clair Co Library Sheldon R-VIII Shell Knob 78 Stone Co Library - Blue Eye Br Stone Co Library - Main Br Willow Springs Public Library
Outage: up to 6 hours
Description: Lumen will be doing a fiber cable relocation necessary to proactively prevent damage and to comply with MO-DOT construction. Due to the nature of this maintenance, an alternate night (5/16/25) may be needed to complete the relocation. Expect outages throughout the duration of the maintnenace period.
Posted May 07, 2025 - 08:19 CDT
This scheduled maintenance affected: MOREnet Network (Carrier Network).