St. Louis Area Fiber Cut

Incident Report for MOREnet Service

Resolved

AT&T confirmed cards had to be replaced to restore services and technicians are now hands off.
Posted Nov 07, 2025 - 20:23 CST

Monitoring

Alarms have cleared and service restored. Awaiting final confirmation of repair from AT&T.
Posted Nov 07, 2025 - 18:11 CST

Update

AT&T is still pending technician dispatch to the central office to troubleshoot a DWDM failure.
Posted Nov 07, 2025 - 15:11 CST

Identified

AT&T has isolated the issue to a failed card in an AT&T central office. They are pending tech dispatch to the location. No ETA at this time.
Posted Nov 07, 2025 - 13:22 CST

Investigating

There appears to be a large fiber cut affecting KPower and AT&T backhaul near St. Louis, MO. We are working with vendors to locate. Affected sites are as follows:

A T Still University - St. Louis
Affton High - Affton 101
Boncl R-X
Butler R-V
Callaway County Public Library - Daniel Boone Regional Library
Davis R-XII
El Dorado Branch - Cedar County Library
El Dorado Springs R-II
Fulton 58
Gideon 37
Hancock Place
Hannibal Campus - Moberly Area Community College
Hannibal LaGrange University
John Burroughs School
Kennett Higher Education Center - SEMO
Korf Gymnasium/Administration Building - Hannibal 60
Leopold R-III
Main Library - Mississippi County Library
Maplewood Public Library
Mexico Branch - Mexico-Audrain County Library
Mexico Campus - Moberly Area Community College
Midway R-I
Mitchell Memorial Library - Mississippi County Library
Osage Beach Library - Camden County Library
Poplar Bluff Public Library
Rhodes Memorial Library - New Madrid County Library
Union R-XI Middle School
University Physicians Fulton
Webster Groves Public Library
Zalma R-V

Updates will follow.


MOREnet NOC
Posted Nov 07, 2025 - 12:36 CST
This incident affected: MOREnet Network (MOREnet Aggregation).