MOREnet Fiber cut in South County, MO
Incident Report for MOREnet Service
Resolved
Fiber was repaired at 3:30PM.
Posted Sep 17, 2022 - 15:39 CDT
Investigating
We are currently experiencing a fiber cut between South County and Vallesmines. All services are protected. No ETR at this time.
Posted Sep 17, 2022 - 10:16 CDT
This incident affected: MOREnet Network (MOREnet Aggregation, MOREnet Fiber).