Root Cause: A failed hardware component in Jefferson City, MO, impacted client services.
Fix Action: Network Operations Engineers completed reboots on multiple cards, resulting in improved network conditions
Posted Jun 30, 2026 - 21:26 CDT
Resolved
This incident has been resolved.
Posted Jun 30, 2026 - 21:25 CDT
Update
Network Operations Engineers successfully completed targeted remediation activities, resulting in improved network performance. Validation efforts are currently underway to confirm continued service stability. As a proactive measure, replacement hardware is being secured and will be installed during a scheduled maintenance window to further enhance network reliability
Posted Jun 30, 2026 - 21:19 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 30, 2026 - 20:39 CDT
Update
Issue is still under investigation. No ETR at this time.
Posted Jun 30, 2026 - 19:47 CDT
Investigating
Sites: Appleton City Public Library Green Ridge R-VIII Henry R-I Hudson R-IX Lenora Blackmore Branch - Henry County Library Montrose R-XIV Main Branch Harrisonville - Cass County Library Oak Hill R-1 Strasburg C-3
Description:
Vendor related issue, suspected fiber cut under investigation. Updates will be posted as given. Tickets have been created with the vendor.
Posted Jun 30, 2026 - 18:24 CDT
This incident affected: MOREnet Network (MOREnet Internet, Carrier Network).