Outage Between South County and Valley Mines

Incident Report for MOREnet Service

Resolved

This incident has been resolved.
Posted Jul 10, 2026 - 09:51 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2026 - 09:32 CDT

Investigating

We are currently investigating this issue.
Posted Jul 09, 2026 - 03:29 CDT
This incident affected: MOREnet Network (MOREnet Aggregation, MOREnet Fiber).