Fiber Cut St Louis Area

Incident Report for MOREnet Service

Resolved

Fiber has been repaired.
Posted May 18, 2025 - 17:57 CDT

Update

Spectrum technician were able to get hands on at 9pm last night. They are currently working on splicing fiber now.
Posted May 18, 2025 - 08:13 CDT

Update

Crews are onsite but still no ETR at this time as damage is wide spread.
Posted May 17, 2025 - 17:36 CDT

Investigating

MOREnet is experiencing a fiber cut in Spectrum's Network in St Louis Area. No outage is being experienced by members as traffic is rerouting. Telco reports "ongoing efforts to restore services as quickly as possible. Spectrum construction crews are spread thin due to the recent storm damages in the St. Louis area"
Posted May 17, 2025 - 12:49 CDT
This incident affected: MOREnet Network (MOREnet Internet, MOREnet Backbone, MOREnet Fiber).