Centurylink Outage 2/24/26

Incident Report for MOREnet Service

Resolved

As of 6:29 am, we are hands off, all clear.
Posted Feb 25, 2026 - 06:57 CST

Monitoring

Services are restoring as splicing activities are being completed
Posted Feb 25, 2026 - 05:22 CST

Update

Utility locates are in place, excavation commencing
Posted Feb 24, 2026 - 20:18 CST

Update

onsite efforts to expose the damaged cable section by hand has commenced while pending the completion of emergency utility locate markings onsite. Once completed, crews will expose the damaged cable section, install two new splice enclosures at each end of the damage location, and place a new fiber section to restore services. Emergency utility locates are anticipated to be completed onsite in approximately 1 hour.
Posted Feb 24, 2026 - 19:19 CST

Update

Fiber crews are working on a restoration plan for this repair as the fiber is located in a creek and near an active construction area.
Posted Feb 24, 2026 - 19:14 CST

Update

Techs are onsite making repairs, no ETA given as of yet.
Posted Feb 24, 2026 - 17:12 CST

Update

Field crews have identified another area of damage, not too far from the initial fault, due to a construction project. ETA will be given once splice and repair team assess the work that needs to be done.
Posted Feb 24, 2026 - 15:58 CST

Identified

Their is a fiber fault near Cassville, MO. Technicians are undergoing isolation & troubleshooting. No ETR given.
Posted Feb 24, 2026 - 15:17 CST

Update

This outage is part of a higher level outage under investigation. "Boots are on the ground" in an attempt to locate and isolate the fault.
Posted Feb 24, 2026 - 14:10 CST

Investigating

Sites:
Barry-Lawrence Regional Library:
Eagle Rock Branch, Shell Knob Branch
Dadeville R-II
Hurley R-I
Manes R-V
Shell Knob 78

Centurylink outage is under investigation.
Posted Feb 24, 2026 - 13:13 CST
This incident affected: MOREnet Network (MOREnet Internet, Carrier Network).