Lumen Outage:

Incident Report for MOREnet Service

Update

field tech have been dispatched to locate/isolate fault. No other updates to report yet. No ETR.
Posted Aug 12, 2026 - 16:28 CDT

Update

reporting Field Operations have been engaged to dispatch a technician to the site and perform light level readings on the fiber to isolate the point of failure
Posted Aug 12, 2026 - 15:07 CDT

Update

technicians are actively working on this issue and are currently collaborating with multiple internal teams to gather all relevant details. Our focus is on validating the accuracy of the information to ensure we provide a clear and complete update.
Posted Aug 12, 2026 - 13:21 CDT

Update

An equipment failure in Saint Louis and Joplin, MO impacted unprotected traffic. Remote reconfiguration was put in place but, these impacted sites have remained down. Further investigation is underway to locate the fault.
Posted Aug 12, 2026 - 11:11 CDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 12, 2026 - 09:11 CDT

Update

A configuration change has been made and restoration of services is seen on equipment out in the field however I am still seeing our edge routers offline. It has been adviced to reboot the equipment. Will update once this has been done.
Posted Aug 12, 2026 - 07:16 CDT

Identified

Fileld operations are onsite to begin troubleshooting. No ETR has been given.
Posted Aug 12, 2026 - 06:45 CDT

Update

10g NNI link in Saint Louis, MO went down today 8/11/2026 at 19:17 GMT. Fiber transport outage between Saint Louis to Branson, MO is affecting multiple services in the area. Engineers have been engaged and working on isolating fault. No ETR has been provided
Posted Aug 11, 2026 - 22:56 CDT

Investigating

Sitess
Hurley R-I
Manes R-V

Description:
This is a higher level outage being investigated by Lumen. Isolation efforts are ongoing. No ETR given.
Posted Aug 11, 2026 - 19:45 CDT
This incident affects: MOREnet Network (MOREnet Internet, Carrier Network).