Aggregation Fiber Cut

Incident Report for MOREnet Service

Update

We are seeing some circuits start to come up. Once we get official word that Lumen is hands off, we will resolve this incident.

MOREnet NOC
Posted Jun 17, 2026 - 20:05 CDT

Identified

Lumen NOC has confirmed the outage and is engaging the Local Exchange Carrier to further isolate damage. Updates will follow.

MOREnet NOC
Posted Jun 17, 2026 - 16:06 CDT

Investigating

MOREnet engineers are investigating a possible fiber cut affecting some Lumen and Charter aggregation. Updates will follow.

Affected sites:
Centerville R-I
Centerville Branch (Main) - Reynolds County Library
South Iron Co. R-I (High School)
Lesterville R-IV
Lesterville Branch - Reynolds County Library
Bunker Branch - Reynolds County Library
Bunker R-III
Belleview R-III
Annapolis Branch - Ozark Regional Library

MOREnet NOC
Posted Jun 17, 2026 - 14:05 CDT
This incident affects: MOREnet Network (MOREnet Aggregation).