MOREnet fiber cut between St Louis and South County.

Incident Report for MOREnet Service

Monitoring

The fiber has been repaired. The underlying carrier will be working for the next few days to repair the remaining fiber damage due to the weather damage. Outages are not expected but due to the circumstances, it may be unavoidable.
Posted May 21, 2025 - 21:51 CDT

Investigating

We are currently investigating this issue.
Posted May 21, 2025 - 08:15 CDT
This incident affects: MOREnet Network (MOREnet Fiber).