Lumen has replaced the card and all services have now restored. We will monitor throughout the day for any further issues.
Posted Mar 18, 2025 - 11:23 CDT
Update
The replacement card has been ordered with an ETA of 11:00AM. Once the new card is obtained, Field Operations will dispatch to the failure site to perform the replacement.
Posted Mar 18, 2025 - 09:22 CDT
Identified
Lumen reports a remote reset of the affected card was attempted, to no avail. As such, a replacement card is being ordered and Field Operations are being coordinated to receive the card and perform the replacement. No ETA for the card.
Posted Mar 18, 2025 - 08:30 CDT
Update
Lumen is reporting that initial investigations have identified a suspected card failure to be the cause of impact to services. No ETR yet.
Posted Mar 18, 2025 - 07:29 CDT
Update
Lumen optical engineers are still investigating the cause of a network outage in the St Louis MO area. No ETR has been provided. We continue to escalate for updates.
Posted Mar 18, 2025 - 06:20 CDT
Update
Lumen techs are currently troubleshooting issue. We continue to escalate our tickets.
Posted Mar 18, 2025 - 00:05 CDT
Investigating
Several Lumen circuits down at approximately 7:40PM. Tickets currently open and escalated with Lumen NOC for troubleshooting. Circuits affected are listed below.
Belleview R-III Centerville R-I Crawford County Library District Recklein Memorial Branch Heartland Regional Library Belle Branch Lesterville R-IV Maries Co R-II Middle School Mexico-Audrain County Library Laddonia Branch Reynolds County Library Bunker Branch Reynolds County Library Centerville Branch Reynolds County Library Lesterville Branch Scenic Regional Library Wright City Branch South Iron Co R-I Washington County Library
Posted Mar 17, 2025 - 21:53 CDT
This incident affected: MOREnet Network (Carrier Network).