MOREnet Stoutland cooling issue.

Incident Report for MOREnet Service

Resolved

This incident has been resolved.
Posted Jun 20, 2025 - 21:46 CDT

Investigating

MOREnet's Stoutland hub location is currently experiencing a cooling issue. We are currently investigating.
Posted Jun 20, 2025 - 13:27 CDT
This incident affected: MOREnet Network (MOREnet Backbone, MOREnet Fiber).